[CentOS] CentOs 5.6 and Time Sync

Fri Apr 15 15:42:10 UTC 2011
Nataraj <incoming-centos at rjl.com>

On 04/15/2011 04:08 AM, Johnny Hughes wrote:
> On 04/14/2011 06:23 AM, Mailing List wrote:
>> On 4/14/2011 6:47 AM, Johnny Hughes wrote:
>>> Is it really true that the time is working perfectly with one of the
>>> other kernels (the older ones)?
>>    Johnny,
>>       Yes, As long as I run the older 5.5 kernel my time is perfect. All
>> clients can get from this machine with no issues. As soon as I run new
>> kernel, or Plus kernel for that matter. The time goes downhill. "Uphill
>> actually"
>>     To answer the previous question I do have the HW clock set to utc,
>> Everything is stock from initial install of the package.
>> Brian.
> I do not see anything from Dell that is a model C151.
> I also do not see anything in the RH bugzilla that is problematic for
> older AMD processors and the clock, unless running KVM type virtual
> machines.
> Is this a VM or regular install?
> If this a real machine, do you have the latest BIOS from Dell?
> Do you have any special kernel options in grub?
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
It also occured to me to ask if this was running in a VM, but it sounded
like it was running on actual hardware.    I once had a vmware VM in
which I had similar misbehavior of the clock.  Eventually I discovered
that the following simple program when run inside the VM would return
immediately instead of delaying for 10 seconds as it should.

#include <stdio.h>
/* #include <sys/select.h> */
#include <sys/time.h>
#include <sys/types.h>
#include <unistd.h>

int main() {
fd_set set;
struct timeval timeout;
int filedes = STDIN_FILENO;

FD_ZERO (&set);
FD_SET (filedes, &set);

timeout.tv_sec = 10;
timeout.tv_usec = 0;

select(FD_SETSIZE, &set, NULL, NULL, &timeout);


I then found out that the ISP had set the host OS for my VM to Ubuntu
when I was running CentOS 5 in the VM.  The cause was that VMware
assumed a tickless kernel for Ubuntu, but not for CentOS 5 and there
were optimizations in the VM emulation that counted on VMware knowing
what timekeeping options where set in the kernel.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20110415/7c0bf8c7/attachment-0003.html>