[CentOS] can not install CentOS as VM in KVM

Sat Apr 23 07:19:45 UTC 2011
Jussi Hirvi <listmember at greenspot.fi>

On 6.4.2011 15.44, Michael Zoet wrote:
> I am trying to install CentOS 5.5 as VM on a KVM server running Ubuntu
> 10.04. The Problem: the installer does not find the iso image. (Direct
> copy from website downlod.) I can start CentOS from the iso and can even
> do some disk checks. But when I go further the installer says "no CDROm
> found". Pretty weird. I tried all CentOS 5.5. image available (Live CD,
> net install, bin 1 of 8, 32 bit and 64 bit).
> Other installation (Debin, Ubuntu, SLES, Windows XP, Windows 7, Windows
> Server 2008) worked fine.
> Perhaps somebody can help me in setting things up for that.

Did you already solve this?

I do text-based installations with virt-install, and follow this procedure:

- if you are going to do several VM installations, then before you 
install, copy the directories you need (for example 
centos/5.6/os/x86_64/) from a CentOS mirror to /var/www/html on the host
- start httpd on the host, check in the browser that you can access the 
CentOS files

- from a CentOS mirror, download any bootable iso (netinstall cd, or 
installer cd #1 do fine) to the host
- mount the iso using "mount -o loop"

- do virt-install
	- for "location", use the mounted iso
	- do a "http" installation using your local http "repo" (refer to the 
host with its public ip number; did not work for me)

- Jussi