[CentOS] Install CentOS as KVM guest

Thu Apr 28 05:11:10 UTC 2011
Emmanuel Noobadmin <centos.admin at gmail.com>

On 4/28/11, Jussi Hirvi <listmember at greenspot.fi> wrote:
> I understand you so well, I have been so frustrated too with
> virt-install. Virt-manager is probably an easier way to install, but
> text-based virt-install is very cranky (my experience). Maybe the devs
> concentrate on the GUI side. Hope not.

Thanks, it helps to know I'm not alone in feeling frustrated over the process.

> Anyway, to know what is wrong, more info would be needed... Especially,
> at what point does the installation stall.
> Here is one of my install commands that worked:
> virt-install --name mail \
> --os-variant rhel5.4 --ram 1024 \
> --vcpus 2  --accelerate \
> --nographics -v \
> --location /mnt/centos56/  --network bridge:br0 \
> --disk path=/kvmail/mail.img,size=290 \
> --extra-args "console=ttyS0";

I have pretty much the same thing except the names are slightly
different and I've already created the disk with qemu-img so the size
was omitted.

> No other bridge is necessary - I think it would only make things messy.
> In the installer let it configure interface with dhcp, if applicable, or
> give it a free ip.

Did you have to configure an additional tap interface? It seems like
it might be necessary but all the guides just involve giving some
command to create a temporary tap... which doesn't sound very safe if
I want it to persist after a reboot. But I couldn't find any
instructions on how a tap could be defined using a file like

> In giving the http repo remember the slash after the subdirectory, for
> example (I noticed it is necessary)
> address:
> directory: centos/4.9/os/i386/
> This would be
> Check in your browser that the path works. The stage2 image should
> appear in seconds from a local repo!

I did this too, although my path was just centos56/
Just in case the guest VM was connecting in an around about manner and
iptables was blocking what appears to be an external connection. I
tested that it was accessible from both a VNC session on the host
itself, as well as from external network.

So this is where my installation halts. I will get the message unable
to retrieve

Just to be sure it was not just accessible but downloadable, I tried
to download this exact URL including the double slash and it works.

So it seems to me that the VM's networking is wrong somehow.
Especially since the assigned IP is not pingable during this point.
But I can't be sure if that's just because the OS is still being