[CentOS] Install CentOS as KVM guest

Thu Apr 28 15:58:35 UTC 2011
Emmanuel Noobadmin <centos.admin at gmail.com>

On 4/28/11, Gleb Natapov <gleb at redhat.com> wrote:
> Qemu is not intended to be used directly by end user. It is too complex as
> you already found out. VMware don't even give you access to such low parts
> of virt stack. You should use libvirt or virt-manager instead. Especially
> if you are concerned about security. I think libvirt can start guest on
> headless server.

Sorry for the confusion, I was using libvirtd in CLI, i.e.
virt-install and virsh, not qemu directly.

> If this still fails for you you need to complain to libvirt developers
> (not in a rant mode, but providing details of what exact version of
> software you have problem with and what are you trying to do). And
> libvirt developers will not be shy to complain to qemu developers if the
> problem turned to be on their side.

Apologies about the rant mode as well. Before that, I tried sending
two emails (25th and 26th Apr) to the KVM list with some details,
hoping to get some advice. But each of these failed to materialize on
the kvm list for unknown reasons.

So I resorted to posting to the CentOS list, where I did get some
response for which I'm very thankful. The rant post came when despite
the additional advice which helped me get a little further, I keep
running into unexpected brickwalls like anaconda not seeing the "dvd"
(mounted ISO specified using --location) that it just booted from.

Out of frustration, I CC'd that particular email to the kvm list,
figuring that since it's likely to get me flamed, the imp of
perversity would probably let it through... and it did.

> As far as I know libvirt has no problem using bridged networking and
> virt-manager use libvirt so it should work if you use new enough virt
> stack, but you should ask on libvirt mailing list instead.

I guess those were outdated warnings on older versions. I'll give it
another spin given some of the new suggestions like using virt-install
to create the disk file. If it still doesn't work, I'll go check the
libvirt ML (I'm belatedly getting the idea that libvirt is not part of