[CentOS] kmod-e1000e and Intel Network Card

Wed Feb 16 00:27:51 UTC 2011
Soporte Virtual <soportev at gmail.com>

2011/2/15 Soporte Virtual <soportev at gmail.com>:
> Hi list
> It's my first message here, but I use CentOS from long time ago (sorry my
> language, I'm spanish from Colombia)
> I have a Intel board with an Integrated Network Card 82578DC. I've
> sucessfully installed the driver with the RPM kmod-e1000e; I've found it in
> ElRepo.org, and I've installed it via Yum.
> After I've installed the package (see this:
> http://lists.elrepo.org/pipermail/elrepo/2010-December/000416.html ), I do:
> ifdown eth1
> modprobe -r e1000e
> ifup eth1
> After these steps, my card works OK and get a valid IP address. However,
> when I reboot my machine, I must write those commands again. I've tried to
> put e1000e in /etc/modprobe.d/blachlist; however, it doesn't works.
> Does anubody knows what must I do to have my network card working from
> start?
> Thanks!

Hi again, list!

I've solved it! I've checked in
/etc/sysconfig/networking/devices/ifcfg-eth1, and it had ONBOOT=no.
With ONBOOT=yes issue was solved.