[CentOS] openoffice & command line printing

Fri Feb 18 01:29:58 UTC 2011
Gregory P. Ennis <PoMec at PoMec.Net>


I am trying to print some *.doc files from the command line with
openoffice on centos 5.5 with using cups as the print server.

I can open the file from the command line with open office and then
print it manually from the gui, but when I open the file and print from
command line I am not getting anything.

The commands that I have used are the following :

/usr/bin/openoffice.org -pt lpt4 /mnt/lp/document.doc

/usr/bin/openoffice.org -pt lpt4 -p /mnt/lp/document.doc

/usr/bin/openoffice.org -headless -pt lpt4 -p /mnt/lp/document.doc

/usr/bin/openoffice.org -headless -pt lpt4 -p /mnt/lp/document.doc

In each of these cases the command line finishes back to the "#" prompt,
but nothing prints on lpt4.  Has anyone tried to use the command line
options for openoffice and have the syntax as to how it works.

Thanks much for any assistance you can give me.


Here are some additional attempts 

I tried to create a macro and use it from the command line as well.

openoffice.org -invisible /mnt/lp/document.doc "macro:///Standard.Module1.print_lpt4"

The above command starts openoffice in the gui; this command
automatically prints the document to lpt4 and openoffice remains open
until it is closed by the user.

openoffice.org -invisible /mnt/lp/john_deere_exam.doc
"macro:///Standard.Module1.print_lpt4" -terminate_after_init

The above command executes but nothing happens on the printer and the
command line prompt is returned.

It looks to me like openoffice is not opening up document.doc when the
command line is used.  Is there a way to activate a debug switch to see
what is happening?