[CentOS] problems with createrepo

Tue Feb 22 11:25:31 UTC 2011
Janez Kosmrlj <postnalista at googlemail.com>

I run a local repo for our company's packages. Since yesterday we have
problems with creating the repo files. When i run "createrepo --update -s
sha rpmdir" i get the folowing error:

File "/usr/share/createrepo/genpkgmetadata.py", line 249, in ?
  File "/usr/share/createrepo/genpkgmetadata.py", line 223, in main
  File "/usr/lib/python2.4/site-packages/createrepo/__init__.py", line 368,
in doPkgMetadata
  File "/usr/lib/python2.4/site-packages/createrepo/__init__.py", line 532,
in writeMetadataDocs
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 1032, in
    msg += misc.to_unicode(self._dump_base_items())
  File "/usr/lib/python2.4/site-packages/yum/packages.py", line 866, in
    msg = """
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc2 in position 83:
ordinal not in range(128)

I didn't change anything on the server and it fails on packages that are
more than a year old. It usually fails on package number 200-206. When i
move the supposedly broken package to a new directory and run createrepo on
that directory, then createrepo finishes OK.

I googled a bit, but i couldn't find anything useful. Has anyone on this
list seen something similar and what was the problem.

thanx in advance
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.centos.org/pipermail/centos/attachments/20110222/ffe7c02e/attachment-0004.html>