[CentOS] Set font and size in xterm

Mon Jan 10 19:43:01 UTC 2011
James B. Byrne <byrnejb at harte-lyne.ca>

On Mon, January 10, 2011 12:37, Bill Campbell wrote:
> On Mon, Jan 10, 2011, James B. Byrne wrote:
>> I copied your file into my home directory as ~/XTerm and took a
>> look at its contents.  As far as I can see you did not intend
>> for me to make any alterations to it to begin with.
> James:
> I sent the entire file FYI, and it's yours to hack as you see
> fit.  Lines starting with "!" are comments and may be removed.

Thanks.  I thought as much.

It really does seem to come down to the fact that xfs is not finding
the fonts and that therefore only the default fonts are left
available to XTerm.  I have tried configuring the FontPath argument
in xorg.conf but all that manages to do is to stop the xserver from
starting at all.

I looked into the rc script and to me it is a nightmare.  To begin
with, instead of just configuring the font directories the startup
script runs a font locater utility /usr/sbin/chkfontpath. When run
from the command line this yields these results:


But when I run xset q I do not see these listed:

Font Path:
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
Font cache:
  Server does not have the FontCache Extension
File paths:
  Config file:  /etc/X11/xorg.conf
  Modules path: /usr/lib64/xorg/modules
  Log file:     /var/log/Xorg.0.log

I would appreciate some guidance on how to proceed from this point.

***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3