[CentOS] problems with OpenVPN 2.1.4 on Centos 5.5

Thu Jan 20 18:39:06 UTC 2011
m.roth at 5-cent.us <m.roth at 5-cent.us>

Boris Epstein wrote:
> On Thu, Jan 20, 2011 at 12:39 PM,  <m.roth at 5-cent.us> wrote:
>> Boris Epstein wrote:
>>> On Thu, Jan 20, 2011 at 12:03 PM, Joseph L. Casale
>>> <jcasale at activenetwerx.com> wrote:
>>>>>[root at gw5fl 2.0]# . ./vars
>>>>>bash: /usr/share/doc/openvpn-2.1.4/easy-rsa/2.0/whichopensslcnf:
>>>>>Permission denied
>>>> See that error above? Make that script executable... It's a bash
>>>> script `vars` is calling and not able to execute.
>>> Thanks, did that though this did not fix my problem - I still get the
>>> same error message.
>> Two questions: first, what's the ownership of the file, and the
>> directory, and second, is selinux enforcing?
> The SELinux is enforcing.
> The easy-rsa directory/file permissions are as follows:
> [root at gw5fl ~]# find /usr/share/doc/openvpn-2.1.4/easy-rsa/2.0 -exec
> ls -ld {} \;
You missed it; first, find will cheerfully accept -ls, you don't need
-exec ls... except in this case, where you need ls -alZ, to see the
selinux contexts, including on the directories (which ls -l doesn't show).