[CentOS] libsrtp package anywhere?

Wed Jan 26 16:01:47 UTC 2011
Bob Beers <bob.beers at gmail.com>

On Wed, Jan 26, 2011 at 9:38 AM, JohnS <jses27 at gmail.com> wrote:

Hi John,

 Thanks for the response!

> On Tue, 2011-01-25 at 17:07 -0500, Bob Beers wrote:
> It's your build environment that's the problem.  They build for el5.
> Clean out your build root and recreate it and do a fresh .rpmmacros
> file.

I'm trying to understand your instructions.  I think my build environment
 is not too bad.  I build many other rpms from spec files.  Most of those
 spec files have a line exactly like or similar to:

BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)

but this libsrtp.spec file does not.  So it appears that at the point where
 DESTDIR is specified, the literal value '%{buildroot}' is used.

In my trace ...  make install 'DESTDIR=%{buildroot}'
In yours ...  make install

BTW, here is fedoraproject info on BuildRoot:
I bet I can make it work by adding a BuildRoot: line to the spec file.

Where/how is %{buildroot} defined in your build environment?
Are you building on a CentOS/RHEL 5.X machine?

I have simplified my ~/.rpmmacros file to just these two lines:

$ cat ~/.rpmmacros
%_topdir        /home/bbeers/redhat/
%_smp_mflags -j3

and I still get the same errors.
> John
> Wrote: /home/ethan/rpmbuild/SRPMS/libsrtp-1.4.4-2.20101004cvs.el5.em2.src.rpm
> Wrote: /home/ethan/rpmbuild/RPMS/x86_64/libsrtp-1.4.4-2.20101004cvs.el5.em2.x86_64.rpm
> Wrote: /home/ethan/rpmbuild/RPMS/x86_64/libsrtp-devel-1.4.4-2.20101004cvs.el5.em2.x86_64.rpm
> Wrote: /home/ethan/rpmbuild/RPMS/x86_64/libsrtp-debuginfo-1.4.4-2.20101004cvs.el5.em2.x86_64.rpm

Glad to see it worked in your environment.

-Bob Beers