[CentOS] perl-Nagios-Plugin-0.35-1.el5.rf.noarch from rpmforge: dependency problem

Dirk dirk.schulz at kinzesberg.de
Sun Jul 31 17:51:32 UTC 2011


Hi folks,

I hope this is the right mailing list to ask since on the repoforge 
website there is no list or contact information.

I have a problem with updating the perl-Nagios-Plugin package. I have 
installed perl-Nagios-Plugin-0.33-1.el6.rf.noarch, and running yum 
update leads to:

> Error: Package: perl-Nagios-Plugin-0.35-1.el6.rf.noarch (rpmforge)
>            Requires: /usr/local/bin/perl
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest
>
I do not see how to get this fixed; enabling rpmforge-extras and 
rpmforge-testing did not work (no /usr/local/bin/perl there), and 
symlinking /usr/local/bin/perl to stanard perl did not work either.

I run into this problem on CentOS5 and 6, the latter both in 32bit and 
64bit. And I do not find any hint on Google. Am I the only one to use 
this package? :-)

Any hint or help is appreciated.

Dirk



More information about the CentOS mailing list