[CentOS] Error: Missing Dependency: libgnokii.so.4()(64bit) is needed by package 6:kdepim-3.5.10-2.el5.x86_64 (installed)

Chris Ross cnts5645 at tebibyte.org
Wed Mar 2 16:10:08 UTC 2011


Hi Y'All,

Yum update on CentOS 5 has for the last week or so started giving me the 
following errors


root at neodymium 16:03:46 ~ # nice yum upgrade
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
  * addons: mirror.sov.uk.goscomb.net
  * base: mirror.sov.uk.goscomb.net
  * epel: mirror01.th.ifl.net
  * extras: mirror.sov.uk.goscomb.net
  * rpmfusion-free-updates: mirror01.th.ifl.net
  * rpmfusion-nonfree-updates: mirror01.th.ifl.net
  * rpmfusion-nonfree-updates-testing: mirror01.th.ifl.net
  * updates: mirror.as29550.net
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libgnokii.so.4()(64bit) for package: kdepim
---> Package gnokii.x86_64 0:0.6.29-1.el5 set to be updated
--> Processing Dependency: libical.so.0()(64bit) for package: gnokii
--> Running transaction check
--> Processing Dependency: libgnokii.so.4()(64bit) for package: kdepim
---> Package libical.x86_64 0:0.46-2.el5 set to be updated
--> Finished Dependency Resolution
6:kdepim-3.5.10-2.el5.x86_64 from installed has depsolving problems
   --> Missing Dependency: libgnokii.so.4()(64bit) is needed by package 
6:kdepim-3.5.10-2.el5.x86_64 (installed)
Error: Missing Dependency: libgnokii.so.4()(64bit) is needed by package 
6:kdepim-3.5.10-2.el5.x86_64 (installed)
  You could try using --skip-broken to work around the problem
  You could try running: package-cleanup --problems
                         package-cleanup --dupes
                         rpm -Va --nofiles --nodigest




None of the three workarounds listed work.

Is there any action I should take or should I just wait for the problem 
to be resolved "upstream"?

Suggestions welcomed, I would be grateful for the benefit of your 
collective wisdom.

Many thanks,
Chris R.




More information about the CentOS mailing list