[CentOS] Cannot %include in CentOS 5.5 kickstart

whitivery co55-sy1t at dea.spamcon.org
Fri Mar 18 06:24:24 UTC 2011

whitivery <co55-sy1t at dea.spamcon.org> wrote:

>whitivery <co55-sy1t at dea.spamcon.org> wrote:
>>Patrick Lists
>><centos-list at puzzled.xs4all.nl> wrote:
>>>On 03/10/2011 08:14 AM, whitivery wrote:
>>>> # This does not work
>>>> %include /tmp/drvdisk
>>>> # This works
>>>> #driverdisk
>>>> --source=nfs:
>>>> %packages
>>>> @base
>>>> @core
>>>> %pre --erroronfail
>>>> echo "driverdisk
>>>> --source=nfs:">
>>>> /tmp/drvdisk
>>>Although lacking a good caffeine fix the only difference I notice with 
>>>some examples is that they do this:
>>>%include /tmp/drvdisk.sh
>>>echo "driverdisk --source=nfs:" > /tmp/drvdisk.sh
>>>Notice the usage of ".sh" in the drvdisk.sh filename?
>>Thanks for the idea - but it didn't make any difference.  I even did chmod
>>+x on the created file.  I'm suspecting it's something specific to the
>>driverdisk command, I'll play around if I get a chance and see if
>>including other things works as expected - in my previous 4.4 work I never
>>used a driver disk.
>Today I tried including something other than driverdisk (I put the
>partitioning commands in an include file), and it works fine.  So it's
>something specific to the driverdisk command.

Today I tried HTTP instead of NFS for driver disk access.  It made no
difference - works fine when directly in the kickstart file, fails when
attempt to %include it.

More information about the CentOS mailing list