[CentOS] libpq.so.4 missing

Wed May 4 01:38:56 UTC 2011
Johnny Hughes <johnny at centos.org>

On 05/03/2011 04:36 PM, James A. Peltier wrote:
> ----- Original Message -----
> | On 05/03/11 1:50 PM, James A. Peltier wrote:
> | > Anyone else seeing this when trying to install httpd? My mirror is
> | > completely up to date and the machine is a fresh install of CentOS
> | > 5.6
> | 
> | /usr/lib/libpq.so.4 should be a symlink to libpq.so.4.1, which is
> | provided by postgresql-libs
> | 
> | now, I'm running a newer postgres from the yum.postgresql.org
> | repository, they provide libpq.so.4 via compat-postgresql-libs
> I don't have PostgreSQL installed.  I have no need for it to be installed.
> I have run a yum -y clean all on the host which has only @core installed and some necessary packages to build torque and maui
> I have tried to run yum -y install httpd no third party repositories enabled and it fails with the error described earlier.  I even tried with
>    yum -y install httpd --disablerepo=* --enablerepo=base
> no dice.  I'm trying a different mirror on a VM just to be sure it's not me

Do you have any "exclude=" items in your
/etc/yum.repos.d/CentOS-Base.repo or your /etc/yum.conf file ...
specifically is postgresql-libs (or postgresql*) excluded?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 253 bytes
Desc: OpenPGP digital signature
URL: <http://lists.centos.org/pipermail/centos/attachments/20110503/98c15393/attachment-0005.sig>