[CentOS] Fwd: centos Wireless - Broadcom BCM4313

Tue Nov 8 21:35:21 UTC 2011
Milos Blazevic <milos.blazevic at sbb.rs>

Ned Slider wrote:
> I _think_ when one of the elrepo folks tried the latest Broadcom driver 
> source a week or two ago, the driver stopped working for him. No idea if 
> this was el5 or el6, but not a good sign. Apparently it's not that uncommon.
> My recommendation is that if you can find a driver version that works 
> for you, hang on to it!
> I have no idea if Broadcom keep older version sources available or not. 
> If they would relax their draconian redistribution policies we could do 
> a half way decent job of supporting their drivers, but currently that's 
> not the case.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
Actually, that was me testing the driver (over and over again for the 
past 6 months)... Sadly, ever since Broadcom released version of the driver (December 2010), no solid evidence has been 
provided to prove this driver working on RHEL/CentOS 5 to this day - not 
even after the latest release (Oct 25th, 2011).

The whole issue with the driver can be tracked at the ELRepo bug tracker:

As for the original poster is concerned, the only advice I can give, is 
to download an older driver version from:


and attempt compiling it using the Wiki manual 
http://wiki.centos.org/HowTos/Laptops/Wireless/Broadcom, since ELRepo 
.src.rpm for rebuilding the kernel independent ABI driver has been 
provided just a couple of months ago, for a driver which arguably never 
worked (for me and quite a few other people out there).
So, following the manual step by step should get you there, Johan. Also, 
make sure you use NetworkManager instead of network service with your 
WiFi - if the driver turns out to be working, this will save you some 
time and nervs.

*Kind Regards,*
*Milos Blazevic*


Cert. No: 805010564450148