[CentOS] how to get dev/dsp and oss modules back

Sun Nov 13 12:59:09 UTC 2011
Shaun Jones <mister.s.jones at gmail.com>


 I have some older programs that require OSS and /dev/dsp I have tried the
pulseaudio trick with padsp but some work and some don't. I have also
edited the
/etc/modprobe/dist-oss-conf and uncommented the line that says

install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe
snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss

This was supposed to work at least from what I have read to get the modules
back but unfortunately it has not. I have no /dev/dsp at all or any oss
modules when doing
a lsmod. As you can see here

snd_emu10k1_synth       4968  0
snd_emux_synth         30789  1 snd_emu10k1_synth
snd_seq_virmidi         4176  1 snd_emux_synth
snd_seq_midi_event      5815  1 snd_seq_virmidi
snd_seq_midi_emul       5187  1 snd_emux_synth
snd_seq                46091  4
snd_emu10k1           128854  5 snd_emu10k1_synth
snd_rawmidi            18705  2 snd_seq_virmidi,snd_emu10k1
snd_ac97_codec         95710  1 snd_emu10k1
ac97_bus                 942  1 snd_ac97_codec
snd_pcm                66969  3 snd_emu10k1,snd_ac97_codec
snd_seq_device          5354  5
snd_timer              18308  3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc          7080  2 snd_emu10k1,snd_pcm
snd_util_mem            2950  2 snd_emux_synth,snd_emu10k1
snd_hwdep               5320  2 snd_emux_synth,snd_emu10k1
snd                    52754  17
soundcore               6460  1 snd

I have tried it with both pulseaudio installed and pulseaudio not installed
and no go either way.

 So my question is this, have the OSS modules and support been removed from
the kernel like many other distros have done? If so I will have to rebuild
the kernel to get this functionality back which really is no big deal, but
was hoping someone would know something I do not, thanks in advance.

Mister Jones