[CentOS] CentOS 6 is a bear

Sat Oct 8 01:14:19 UTC 2011
Bob Hoffman <bob at bobhoffman.com>

Gotta say, centos has been tough to install and get working.

The anaconda installer makes large drive setups horridly tedious 
(especially if reinstalling a lot).

Package selection seems a bit off...

I did a virtualization package, no custom..did not install qemu, 
libvirt, and all attempts to do any virtualization failed due to 
non-installed packages.

Then I decided to select all the virtualization packages in custom, but 
had selected 'web server' as the base package. I was never able to 
connect to the net here at home...apparently some things with 'modprobe' 
did not install and the eth devices 'does not exist' or something like that.

Then I decided on the entire gnome package, with all the bells and 
whistles...everything worked, but who wants that? I removed some 
packages in gnome to see and reboot made machine dead.
Did that 4 different times with very few package removals.

Did a number of various tries with custom selections, but the 
dependencies seem to not be grabbing all it needs to work. Never got a 
non gnome setup to recognize eth devices (well, one time, but it never 
was able to get the net).

I just installed a custom set up, all virtualization packages- 
virtualization selected as base. I added some gnome stuff and a few 
other doo dads.....booted up..went right to the command line.... no virt 
software works, errors everywhere. Display will not come up (x, vnc, or 
gnome no matter what)..

Every installation, in first boot up had major missing or odd problems. 
One time I booted up with a gnome set up and selinux was stopping 5 
differetn gdm programs..at boot...due to security risks... wtf?

Any attempt to disable or make selinux permissive results in a dead 
machine, unable to ever boot again (left one up for 12 hours, never came 
back up, thought it was relabeling, but no message.)

Removing packages with the gnome running only worked about 10% of the 
time, all others resulted in dead machine at reboot.

I am considering, the only way to actually install and use this as a 
virtualized host is to go full desktop and hope the selinux enforcing 
will not break the system (with all the programs it will not let run on 

I have never, not once, been able to connect to the net in the command 
line setups...I know how to configure eths, network, dns, etc...not 
once, not even dhcp..config eth0 up, etc.. Gnome has not a single issue 
with the same exact file setups.. Many command line setups would not 
even see the eth devices, something about modprobe this or that not 

quite an interesting task. I have now taken the server out of the center 
and am just going to endlessly install until I get a system that is low 
resources and actually allows the virtualization to work.

My last install, with all virt packages selected...?..... cannot run 
virt-manager, libvirt, though some virt programs do work...why? 
something each needed to run was not installed as a 
dependency....<smacks head>

Reinstalling would not be so bad, but the anaconda installer does not 
quite set up the drives the same on a reinstall forcing a deletion of 
partitions and redoing the entire setup..quite annoying

/rant off