[CentOS] Missing stuff in /bin

Fri Oct 21 07:38:22 UTC 2011
Mikko Koivunen <mikko.koivunen at gmail.com>

Hi all

Having a weird issue with CentOS 6. I lost a lot of stuff in /bin/
(cp,rpm,cat and others) on one host, but that was a development
machine and I'm not really sure what happened there.

But now I ran into a similar problem (missing at least /bin/vi and
/bin/cp) on a host where I'm a lot more certain of all that has been
done on the machine.

This is what happened, it's a _complete_ list of what I have done on the host:

- installed centos 6 from dvd .iso, into esxi 4.1 vm
- selected "web server" as base packages in install
- configured network interface
- configured some variables in /etc/profile.d (with vi - note this later)
- installed mysqld and some php packages
- created a backup script in /etc/cron.daily (just does mysqldump and
/var/www gzip'ing)
- removed postgresql
- put some data in mysql db + apache documentroot
- ran yum update
- tried to configure an apache virtualhost - noticed that vi is missing
- noticed that /bin/cp is missing as well
- coreutils & vim-minimal are installed according to rpm

Yum.log shows that during the yum update vim-minimal was updated,
coreutils not, no package removals visible. Can't see anything in
dmesg, root's history, /var/log/secure, /var/log/messages that would
explain this. No one else has access.

I am certain I have not accidentally removed the files.. Anyone seen
anything similar? I'm a bit hesitant to say it's a bug or claim that
yum update is to blame, because then I'd think a lot of folks were
bitten by similar problems.

Mikko Koivunen