[CentOS] How to remove a Trash folder from a mounted ntfs partition

Fri Oct 21 15:24:21 UTC 2011
James B. Byrne <byrnejb at harte-lyne.ca>

CentOS-5.7 using fuse-ntfs-3g

I have a HDD from a laptop that is being returned for
repair replacement.  I wish to remove certain files before
sending the laptop back with the HDD.

I have mouunted the HDD on my desktop as an ntfs
filesystem using an external SATA / USB adapter.  As root
I then used the gnome desktop to move the desired files to
trash.  Now I wish to delete the contents of the trash
folder and the folder itself. This I cannot do.  I have
tried deleting using rm -rf ./.Trash-root but the command
simply has no effect.  It raises no error and it does not
remove the Directory or its contents.

For convenience I renamed the directory to DeleteME using
move, which worked. As expected through, all attempts to
remove DeleteME still fail silently.  The permission bits
are set thus:

dr-xr-xr-x 1 root root 488 Oct 21 10:54 DeleteMe

I have tried chmod -R 777 DeleteMe but this has no effect
on the permissions.

How do I get rid of this thing?

I realize that after the trash directory is removed I will
still have to over-write the unused space on the drive to
scramble the contents but I cannot get to that stage until
I free the space.

***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3