[CentOS] trace?

Tue Oct 11 11:53:34 UTC 2011
hadi motamedi <motamedi24 at gmail.com>

On 10/11/11, John Doe <jdmls at yahoo.com> wrote:
> From: hadi motamedi <motamedi24 at gmail.com>
>> On 10/10/11, John Doe <jdmls at yahoo.com> wrote:
>>>  From: Eero Volotinen <eero.volotinen at iki.fi>
>>>>  2011/10/10 hadi motamedi <motamedi24 at gmail.com>:
>>>>>   I have installed an announcement application on my centos 6.0
>> server
>>>>>   that calls for putting specific voice announcement files under
>>>>>   /usr/local/srf/bin/prompt to be played in response to certain
>>>>>   conditions occurred . There are a huge number of files in the
>>>>>   announcement directory and it seems that just one of these voice
>> files
>>>>>   is corrupt . Can you please let me know how can I trace in real
>> time
>>>>>   to see which application is going to use this folder and which of
>>>>>   these files will be accessed at the moment ? My goal is to find
>> that
>>>>>   corrupted voice file in real time .
>>>>  How about something like this:
>>>>  watch -n 1 lsof /path/to/files
>>>  Or maybe:
>>>    inotifywait -m -e access --format "%T %f" --timefmt "%D
>> %T" -r
>>>  /path/to/files
>> Excuse me, the announcement application program is accessing this
>> folder from time to time to play the appropriate voice announcement
>> file . As there are a huge number of voice files inside this folder,
>> so I need some way to trace to see which file is being accessed when
>> hearing the corrupted voice file . I tried for your "watch" &
>> "inotifywait" utilities but I didn't see any log even when
>> intentionally trying to ftp some files into this folder. It seems that
>> my previous explanation of the problem was not so clear. Sorry again .
>> What can I do to find an appropriate trace method for my case in your
>> opinion ?
> Your previous explanation of the problem was very clear...
> Here is an example when I do:
> # inotifywait -m -e access --format "%T %f" --timefmt "%D %T" -r
> /home/jd/tmp
> Setting up watches.  Beware: since -r was given, this may take a while!
> Watches established.
> $ less toto.php
> ...
> 10/10/11 12:33:21 toto.php
> It detected my read access to the file 'toto.php' in '/home/jd/tmp'
> JD
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos
Excuse me, you are right. I tried again with your "inotifywait"
utility and it notifies me when touching a file . It seems that my
previous attempt had something wrong in it. But it seems that the
"watch" utility brings nothing . Am I right?