[CentOS] ssh -D socks proxy through CentOS-5

Thu Sep 29 18:54:09 UTC 2011
James B. Byrne <byrnejb at harte-lyne.ca>

Is there anything special in the way of configuration that
is required to enable a CentOS box to act as the point of
origin for an http request routed to it via a SOCKS ssh

I have researched this matter and the recommended
procedure is to open an SSH connection to the desired host
passing the requisite switches so:

  ssh -f -n -D <port> user at host.domain.tld

And then reconfigure the desired applications to use the
localhost:<port> as the SOCKS proxy.

However, I cannot seem to get this to work with my CentOS
based desktop to which I am trying to connect through a
public wireless network.  I connect to the desktop via
terminal (on OSX-10.6.8 fine), but setting the browser,
Firefox-3.6.23, advanced network config to use
localhost:<port> as a SOCKSv5 proxy for http simply
results in the browser failing to show anything.  I do not
get any error, I just get a blank page for whatever url I

I have tried this with and without the iptables service
running on the target and achieved the same results.
Therefore I do not consider the firewall configuration on
the target to be the immediate problem.

Has anyone here tried to do this and succeeded?

Supplemental question: How does one route an https
connection to a non-standard port via SOCKS?  How does one
configure a browser to do this?

***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3