[CentOS] an assortment of mail serving issues - PARTIALLY SOLVED

Fri Apr 13 16:35:59 UTC 2012
Jason T. Slack-Moehrle <slackmoehrle at gmail.com>

OK, I solved this, partially. It turns out that this is 

'nearly always caused by a host that is configured on private IP Space (or using NAT) and that does not have an interface for the public IP address the server resides on. This can be easily fixed by simply using native IP address lookups for lmtp rather than DNS'

so a few Zimbra commands and everything works Zimbra wise.

Special thanks to John Stanley for e-mailing me privately about a few things.

The remaining issue is that e-mail from our websites isn't working still

PHP mail functions dont seem to be getting to us.

Items like:

$headers = 'MIME-Version: 1.0' . "\r\n";
$headers .= 'Content-type: text/html; charset=iso-8859-1' . "\r\n";
$mail_to = "jason at thedigiologygroup.org";
$mail_subject = "[6Colors] Contact Requested!";
$mail_body = "<html><body><br />"; 
$mail_body = $mail_body."[6Colors - CONTACT]<br /><br />";
$mail_body = $mail_body."Name: ".$vName."<br />";
$mail_body = $mail_body."E-Mail Address: ".$vEmail."<br /><br />";
$mail_body = $mail_body."Comments: ".$vComment."<br />";
$mail_body = $mail_body."------------ END ------------ <br />";
$mail_body = $mail_body."<br /></body></html>";
mail($mail_to, $mail_subject, $mail_body, $headers);

I tried a test message from the website and then looked at `/var/log/maillog' and I dont see anything.

Any thoughts?