[CentOS] [SOLVED]Perl Libraries

Sun Feb 12 22:15:57 UTC 2012
Rob Kampen <rkampen at kampensonline.com>

On 02/12/2012 01:06 PM, Nicolas Thierry-Mieg wrote:
> Rob Kampen wrote:
>> On 02/12/2012 12:43 PM, Rob Kampen wrote:
>>> On 02/12/2012 10:15 AM, Nicolas Thierry-Mieg wrote:
>>>> Rob Kampen wrote:
>>>>> I am trying to install some perl libs and find the ones from CentOS
>>>>> mirrors are correctly loading the x86_64 versions, but the rpmforge ones
>>>>> are only i386 or i686 ones - any reason why??
>>>> did you check the rpmforge.repo configuration?
>>> yeah, seems identical to another x86_64 server that is working just fine.
>>> The server with the problem is a rebuild and used to be a i386.
>>> Thus there is history on the system that is i386 - but the OS, rpm, yum,
>>> apache, php etc are all x86_64 and as mentioned, there is no problem
>>> pulling files from the CentOS repos - I did need to change
>>> /etc/rpm/platform to get these working and wondered if rpmforge has a
>>> similar place it goes to, to determine the arch??
>> Okay - it seems the centos mirrorlist repos use $basearch which comes
>> from the /etc/rpm/platform file and rpmforge uses $arch which comes from??
> I have $basearch for rpmforge.repo as well, both on C5 and C6.
I did the changes to mirrorlist for rpmforge so it referenced $basearch 
and still no joy.
I then did a "yum clean all" and it came right - I think yum is not set 
up to deal with a change in the arch, thus did not reload the repo file 
All is now well. Thanks all for the suggestions.
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos