[CentOS] QEMU configuration not persistent

Tue Feb 14 01:19:10 UTC 2012
Emmett Culley <emmett at webengineer.com>

On 02/13/2012 04:24 PM, Emmett Culley wrote:
> On 02/13/2012 03:49 PM, Paul Heinlein wrote:
>> On Mon, 13 Feb 2012, Emmett Culley wrote:
>>> Since switching from CentOS 5.7 to CentOS 6.x I find that one of the
>>> VMs will not restart upon system reboot.  I finally figured out that
>>> the video is always set to vmvga after rebooting.  In addition the
>>> VM's storage always reverts back to IDE from virtio and is set to
>>> use the wrong image.
>>> It may be related to the fact that I moved the XML files that
>>> defined the VMs from the old (CentOS 5.7) /etc/libvirt/qemu
>>> directory to the new (CentOS 6.2) /etc/libvirt/qemu directory.  The
>>> images are stored is the same LVM partitions as they were on the
>>> CentOS 5.7
>>> Any ideas why a VM would revert back?  I've checked the XML file
>>> before rebooting and it always has the correct info in it, until
>>> after the reboot.
>> Did you copy the XML file from the 5.7 host to 6.3 host as-is or did
>> you edit it at all during the migration?
>> I've found that I need either to run "virsh define $DOM.xml" and then
>> start the new domain or run "virsh create $DOM.xml" and then, once
>> it's running, make a trivial change (usually adding an XML comment) to
>> the configuration via "virsh edit $DOM" to get things to stick.
> I did copy the XML files to the 6.2 machine.  Then when I found that the VMs would not start because they were set to vmvga video, which doesn't seem to be supported anymore, I changed the XML files to cirrus.
> Then I tried editing the VM using virsh, but still it doesn't persist.
> Hmm. There is only one of the VMs that doesn't persist so I'll try using virsh edit again on that one and make a change as you suggest, just in case I never really changed anything for that VM using virsh edit.
> Thanks,
>    Emmett
Still doesn't persist.  Each time I reboot I have to use virt-manager to change video to cirrus from vmvga, then remove the IDE driver that points to the wrong storage location and add a new virtio storage device pointing to the correct image (an LVM partiiton).

After I make the changes I close virt-manager and restart it, then look at the configuration for the non-persistent VM, and my changes are still there and I can run the VM.

I did a "grep vmvga" on the entire /etc/libvirt directory tree and found no references to "vmvga".  Where can libvirt be getting info to change the xml to vmvga, or the IDE to the wrong location?