[CentOS] Sound drop out with totem. mplayer Can't open audio device /dev/dsp[partially SOLVED]

Sat Feb 18 14:58:53 UTC 2012
John Stanley <john.stanley at elslc.com>

On Fri, 2012-02-17 at 23:43 -0500, Mark LaPierre wrote:

> mplayer still doesn't want to hear it.
> mplayer -ao pulse my.mp3 ====> No Joy
> mplayer -ao alsa my.mp3 ====> No Joy

cat .mplayer/config

Should not have anything in it for a default config.

cat /etc/mplayer/mplayer.conf

Should have this for a default config.

# Default video output is xv, then xvidix, then try others
# Default audio output is pulse, then alsa, then try others

So what does 'mplayer -v 3 my.mp3' say to you?

Did you look at the Mplayer Preferences to see what the output driver
is? "Alsa" Channels by Default?

Have you tried 'rpm -e nodepps mplayer'?  Then 'rpm -Uvh mplayer'.  If
you 'yum remove mplayer' you will remove the whole lock stock and
barrel.  So get the mplayer rpm from the repo you use first then do it.

> padsp mplayer my.mp3 works.

Ok odd but it's not finding alsa / pulse.

> My alsa information is at:
> http://www.alsa-project.org/db/?f=522b3664bd765b464440dabd18c7b2dda0a5e154

Nice Burr-Brown Decoder on the card your using.