[CentOS] Centos6: Boot from usb 3.0ls /

Wed Feb 29 13:31:50 UTC 2012
Volker Poplawski <volker at openbios.org>

On 23.02.2012 14:25, Lamar Owen wrote:
> On Wednesday, February 22, 2012 09:52:54 AM Volker Poplawski wrote:
>> Hi all,
>> I'm booting Centos6 from a usb 3.0 stick.
>> This works fine as long as the usb-stick is connected to a usb 2.0 port.
>> Once I plug the the usb-stick into a blue usb 3.0 port centos fails on
>> mounting the root filesystem.
>> Any hints on that?
> Which version of CentOS?  6.0, 6.1, or 6.2?  Which kernel?
> USB3 support isn't as robust as it should be, prior to 6.2, but I've not tried booting with USB3.0.

Hi Lamar.

Centos 6.2 x86_64,  2.6.32-220

Got the problem (partialy) solved.

The required xhci_hcd kernel module is not part of the 260 modules in 
the initrd for some reason. Sony Memory-Stick is included, if you happen 
to have one of these...

I was able to rebuild the initrd plus the xhci_hdc module:

mkinitrd -v --with=xhci_hdc 
/boot/initramfs-2.6.32-220.4.2.el6.x86_64.img `uname -r`

Now, how do I tell centos to add the module everytime a new kernel is 
OpenSuse offers a setting called INITRD_MODULES="..." in /etc/sysconfig 
which is used by mkinitrd. Is there something similar in Centos?