[CentOS] new mysql installation, kinda stuck

Fri Feb 3 03:52:16 UTC 2012
Bob Hoffman <bob at bobhoffman.com>

I installed centos 6 as a webserver. It installed mysql.
However, I guess I need mysql-server for me to use it for php and my 
I installed that.

I am unable to give root a password and can go no further.
I have tried mysql-secure-installation and I just get stuck at errors 
and no progression.
I have tried mysqladmin -u root password <password> and the accompanying 
that includes the hostname.

ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using 
password: YES)

I am unable to use mysql with php or do anything at all with it.
It was strange it installed mysql but I guess this version is different 
and needs more packages
to work within a webserver.

all attempts at using mysql without mysql-server installed just results 
in nothing being found (like mysqld) and the like...so I had to install 
the server.

In 5.x I could just use mysqladmin and add roots, delete anonymous, etc. 
However, this time I am stuck.

I uninstalled mysql-server, the perl thing that comes with it, and mysql 
itself, then reinstalled them, that got me no where.

gotta be something I am missing here.

thanks for listening.