[CentOS] No eth0 on centos 6.2

Digimer linux at alteeve.com
Thu Jan 5 00:22:11 UTC 2012

On 01/04/2012 06:52 PM, Jeff wrote:
> Just installed centos 6.2.  I run and ifconfig -a I see and em1 
> em2 and lo interface.  If I go to /etc/sysconfig/network-scripts, 
> I don't see an ifcfg-eth0.  If I run ifup eth0 it comes back 
> with "Device eth0 does not seem to be present, delaying 
> initialization".  Anybody have a clue?  Thanks in advance.

The names of the devices are starting to change. The 'emX' are likely
your interfaces. If you check you should have ifcfg-emX files. If you
would like to rename them, you can follow this;


That talks about change eth0 <-> eth1, but it can just as easily be em0
<-> eth0.

E-Mail:              digimer at alteeve.com
Freenode handle:     digimer
Papers and Projects: http://alteeve.com
Node Assassin:       http://nodeassassin.org
"omg my singularity battery is dead again.
stupid hawking radiation." - epitron

More information about the CentOS mailing list