[CentOS] GUI login issues over NFS

Michael Weiner hunter at userfriendly.net
Thu Jan 26 20:51:32 UTC 2012

On Thu, Jan 26, 2012 at 3:40 PM, Thomas Burns <tburns at hawaii.edu> wrote:
> If it was me, I'd try creating a new home directory for that user on a
> disk local to the machine where you're trying to log in. Presumably
> the user could then log in. Then I'd check that the user could access
> the NFS share normally just not as home. If no problem there, I'd be a
> bit tempted to stop there as a workaround, because I am lazy and most
> of my users just use one machine.

I have tried this, but of course i did it as the users $HOME
directory. The reason we do it this way is because we use that file
server to then back up all environmental files and user data. This is
currently working, and has been for years, on other hardware ... we
just purchased the HP at the end of last year, and silly me thought i
would just migrate everything over like i have time and time again :(

> Seems possible to me that the dmrc file error message and the instant
> logout are related but not identical. Gnome just does not like NFS
> home dirs. (My experience has been, if the same user is logged in to
> two machines, kablooey!) I used to frequently see a similar problem,
> after a crash or other odd event, where the user could log in but then
> would immediately be logged out with an error similar to your second
> message. I had a magic trick I had to go through to untangle things,
> if you are desperate enough you could try it:

At this point i supposed i can try anything, this device is not in
production yet for this purpose so i have some leeway and can play

> * delete all files in the user's home dir that start with .gconf
> (.gconf and .gconfd).
> * delete all files in /tmp.
> * reboot to make sure all processes release old corrupted files.
> * if feeling paranoid, before having the user try to log in, check
> again as root that /tmp is empty and nothing in user's home dir is
> named .gconf*.

I basically achieved this same thing by doing an 'adduser newuser' and
providing it a password which then created the $HOME directory on the
NFS mount, and then attempting to login to Gnome or KDE as that user
to no avail - same error

> One of the symptoms of my problem was, after the user tried to log in
> and failed, there would be some processes owned by that user alive or
> in zombie state but still part of ps output, although of course the
> user was not logged in. These must be killed (or overkilled with
> reboot) and all traces in /tmp removed. But this would show up in the
> log of the machine where user is trying to log in (if I recall) as
> some complaint about gconf. So this may be a goose chase for you,
> since KDE also fails. I'm not sure what (if anything) they would have
> in common.

Thanks for the suggestions on some other things to try.

More information about the CentOS mailing list