[CentOS] After a long break, one more try at bond/bridge nics

Bob Hoffman bob at bobhoffman.com
Fri Jan 27 22:16:23 UTC 2012


took a couple months off due to road blocks, hoping a fresh look would 
allow me to use my server as desired.

I have three ports, eth0-2 over two nics.
I want to bond them, and then use a bridge to connect to virtual 
machines on the virtual host computer.
Never having done this, I am confused on some parts.

Here is where I am at now and any pointers helpful. Single server, 
centos 6.x
My issue is do I add the ip address of the virtual host and where?
Do I not add any of the ip addresses of the virtual machines? (thus they 
will be looked for via the bridge?)
Each virtual machine will be getting its own ip address as it will be 
used for a website.

here is the basic configuration I am looking at, with some things not 
added like hwaddress and a few tweaks (zeroconf?)

am I even close? I admit I have never done this and have no mentor other 
than this exceptional mailing list.

============================
/etc/modprobe.conf
alias bond0 bonding
options bond0 mode=balance-alb miimon=100
============================

============================
bond0
DEVICE=bond0
BOOTPROTO=none
BRIDGE=br0
ONBOOT=yes
BONDING_OPTS="mode=1 miimon=100 primary=eth0"
============================

============================
br0
DEVICE=br0
TYPE=Bridge
BOOTPROTO=none
IPADDR=<my virtual host IP address?>
NETWORK=xxx.xx.xx.xxx
BROADCAST=xxx.xx.xx.xx
NETMASK=255.255.255.0
ONBOOT=yes
GATEWAY=xx.xxx.xxx.xx
============================

I did not add the hwaddress to the items below.
========================================
eth0
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

eth1
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

eth2
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none
=========================================




More information about the CentOS mailing list