[CentOS] problem with machine "freezing" for short periods

Fri Jul 27 14:23:06 UTC 2012
Vanhorn, Mike <michael.vanhorn at wright.edu>

On 7/25/12 10:34 AM, "Vanhorn, Mike" <michael.vanhorn at wright.edu> wrote:

>I have two HP dc7800 convertible minitowers that are exhibiting the
>following issue: every 5-10 minutes, they will "freeze" for about 30
>seconds, and then pick right back up again. During the freeze, it seems
>that nothing at all happens on the system; the clock doesn't even advance
>(it just picks up again with the next second, and that 30-or-so seconds
>are lost).
>I've tried both CentOS 5.8 and 5.7, thinking it was a kernel
>incompatibility, but the problem happened with both versions. I have tried
>different hard drives, different memory, even swapped the entire machine,
>and the problem exists everywhere. I have tried adding "pci=nommconf" to
>the kernel line, as that was reported as being necessary back with 5.2 on
>these machines, but that made no difference (and shouldn't be necessary
>now, anyway, as I believe the issue has either been fixed or
>I am stuck, and can't figure out where to even suspect the problem might
>actually be. There are no errors getting logged anywhere that I can find,
>probably because everything just "stops" temporarily, so there's nothing
>for the system to log.
>Does anyone have any idea where I could look to fix this? I think I am
>next going to go back to 5.2, where the pci=nommconf is necessary, because
>at least back that far it appears to have been working for other people.
>However, I really would like to have this running 5.8.

As a followup, I've determined that it is network related, but I'm still
not sure what the problem is. I did go back to CentOS 5.2, but the problem
still exists with that version, too.

Basically, what seems to be happening is that the network freezes around
30 seconds, and then picks right back up. There are no errors in any logs
that I can find, and process that are running locally and that only depend
on local resources keep right on going and don't have a problem.

I have tried using a different network card (as opposed to the one on the
motherboard), but the problem happens with that, too. It almost has to be
a configuration issue, or a BIOS settting, but I don't get it.

Mike VanHorn
Senior Computer Systems Administrator
College of Engineering and Computer Science
Wright State University
265 Russ Engineering Center
michael.vanhorn at wright.edu