[CentOS] ssh port forwarding

Thu Jul 12 17:20:46 UTC 2012
Ski Dawg <centos at skidawg.org>

Hello Everyone,

I am having a problem with setting up port forwarding from one of our local
CentOS machines to an AWS EC2 instance. We are wanting to make mysql
connections over an ssh tunnel.

In this case, lets say that hostA is our local machine, and hostB is the
Amazon EC2 instance. I have tried several different variations (that I have
found from google searching), including:
from hostA: ssh -L 22222:hostB:3306 user at hostB
from hostA: ssh -L 22222:localhost:3306 user at hostB
from hostA: ssh -L 22222:hostB:3306 user at localhost

No matter which variation I have tried, in every case, it will actually
create an ssh connection to the hostB, and log me into hostB, giving me its
prompt. If I try the port (22222) for the localhost (hostA) in another
terminal window, it doesn't allow the connection. netstat also doesn't show
port 22222 to be opened on the local machine (hostA).

I have turned on AllowTcpForwarding on both the remote machine and the
local machine.

I have also made sure that port 22222 is opened on both machine firewalls
(including the EC2 security group).

What am I doing incorrectly or missing?

Registered Linux User #285548 (http://counter.li.org)
Never trust a computer you can't throw out a window.
 -- Steve Wozniak