[CentOS] set perms on ttyUSB

Steve Clark

sclark at netwolves.com
Wed Jun 13 16:45:48 UTC 2012

On 06/13/2012 12:29 PM, James Pearson wrote:
> Steve Clark wrote:
>> Hello,
>> CentOS 6.2.
>> I have spent all morning googling and trying different things to get the permissions
>> on my ttyUSB0 port set correctly using udev. I am at my wits end. Why is this so convoluted!?
>> I would really appreciate it if someone could tell me how to do this.
>> The default permissions come up 660 root,dialout. I have tried adding myself
>> to group dialout but still get permission denied when I run minicom. The only
>> thing that works is sudo -i then chmod 666 /dev/ttyUSB0.
> I have a /etc/udev/rules.d/99-local.rules which contains:
> KERNEL=="tty[A-Z]*",    GROUP="dialout", MODE="0666"
> James Pearson
Thanks James,
That did the trick - I had a similar rule but had munged it in copying it from my browser.

Stephen Clark
Director of Technology
Phone: 813-579-3200
Fax: 813-882-0209
Email: steve.clark at netwolves.com

More information about the CentOS mailing list