[CentOS] network problems

m.roth at 5-cent.us m.roth at 5-cent.us
Thu Mar 1 11:53:09 EST 2012

John Doe wrote:
> From: "m.roth at 5-cent.us" <m.roth at 5-cent.us>
>> I've tried tc qdisc add dev eth0 mq pfifo_fast
>> and tc qdisc add dev eth0  pfifo_fast
>> and neither works. I've googled, and seen something about you can't set
>> something with tc, because pfifo_fast is the hardwired default.
> Not an expert, but this seems to add 'mq' succesfully on my unused eth1:
> eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
> # tc qdisc add dev eth1 root handle 1: mq
> eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN qlen 1000
> But it fails for 'pfifo_fast':
> # tc qdisc add dev eth1 root handle 1: pfifo_fast
> qdisc 'pfifo_fast' does not support option parsing
> Also, maybe you need to delete before adding?

Yeah: after I tried to add it, and it gave me the "does not support
options parsing", I began trying to del the mq, but I can't seem to find
the Magical Syntax (tm) that let's me get rid of that.


More information about the CentOS mailing list