[CentOS] [SOLVED] Software RAID1 with CentOS-6.2

Kahlil Hodgson kahlil.hodgson at dealmax.com.au
Wed Mar 7 00:33:56 UTC 2012

On Wed, 2012-02-29 at 17:43 +1100, Kahlil Hodgson wrote:
> Sadly still getting the same errors.  Will have another go at this
> tomorrow.  Three more things to try
> 1. UBCD and Western Digital diagnostics.
> 2. Bring the RAID array up via the live cd and see if it resyncs.  At
> least I'll be able to inspect the log files when the I/O errors hit.
> 3. Try using the 3Gb/s channel.

Finally got a chance to get back to this (have just moved offices).

1. Tried the WD disagnostics via UBCD and, as predicted, drives came up
all clear.
2. Brought the RAID array up under Partition Majic (via live UBCD) and
it resynced fine.  No amount of prodding could reproduce the errors I
was seeing before. Hmmm...
3. Did a fresh install and got the same problems as before.
4. Poked around in the BIOS to ensure that there were _no_ Fake RAID
settings active.
5. Sigh, okay lets try the 3Gb/s channel ... (face palm!)

On opening the box I noticed the drives were plugged into the GSATA3
ports.  Under a normal viewing angle the 'G' was occluded by the plug
mounts and it wasn't until I took a real close look that I noticed this.
The positioning of the GSATA3 ports on this board was the same as the
normal SATA3 ports on the previous board I used and, I confess, I didn't
read the manual carefully enough <shame face>.  Apparently the GSATA3
ports are controlled by a Marvell 88SE9172 chip rather than the Intel
Z68 chip.

After swapping over to the normal SATA3 ports and rebuilding, updating,
installing, everything is fine :-)

Thanks to everyone for their helpful comments and advice.



More information about the CentOS mailing list