[CentOS] Kickstart network issues

Daniel Lollman daniel.lollman at resonateinsights.com
Fri Mar 16 21:13:34 UTC 2012

Hi Scot -

Thanks for the response. Long term goal is to put Puppet or Chef in place so definitely know that is the direction I want to go, just a matter of finding the time to put it in place.

RPMs - probably would be smart move to do it through cobbler even though the mirrors are local, might play a little nicer..

Problem is that until I can get puppet/chef put up the files bit is still likely to be a problem, and if I can fix that then the RPMs would most likely get downloaded properly too.


-----Original Message-----
From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf Of Scot P. Floess
Sent: Friday, March 16, 2012 5:10 PM
To: CentOS mailing list
Subject: Re: [CentOS] Kickstart network issues

For your RPMs, I'd definitely suggest setting up your own local repos within Cobbler and serving up that way on install - each repo doesnt have to be used for each system you configure...or it can be...

For your files - you might consider using Puppet and have it deploy them post install from a Puppet master?

I know this isn't exactly what you are asking about - just though I'd mention it in case its worth while - as I sort of do something similar myself but using Cobbler/Puppet....

On Fri, 16 Mar 2012, Daniel Lollman wrote:

> Hello all -
> (Please forgive me if I sent this msg twice, first one didn't seem to 
> go through)
> I searched through the archives and did not see anything about this (along with google), but if I missed something please don't hesitate to send me some links.
> Basically I have hit a problem that I cannot figure out at this point and seemed to have ran out of ideas via Google or the documentation.
> I am kickstarting (using cobbler) CentOS 6.2 installs over a private network (can reach the Internet). Part of the installations is to go grab various configuration files, rpm's, etc that are located both internal to the network (different subnet) and externally on the Internet somewhere. This problem seems to be intermittent since it works half of the time, but not the other half.
> Any of my kickstart scripts I have that use local commands (not wget'ing files) work just fine no problems. However when it comes to getting things from the network, it does not always get those files. Usually this errors out with a cannot resolve hostname error or no route to host. I have tried the following to overcome this:
> 1)      During post-install, add a network start and sleep for 120 seconds to give it time to come up.
> 2)      Made sure that the "network" commands in the kickstart included -activate
> 3)      Tried making the downloads not depend on DNS which still does not work (no route to host).
> Are there any tricks to ensuring the network comes up during post-install for kickstart?
> By the way, after the kickstart is done and the VM boots up, there are no changes that need to be made to get the network up and running like normal... DNS, etc work fine immediately.
> Thanks for any help,
> Daniel
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos

Scot P. Floess             RHCT  (Certificate Number 605010084735240)
Chief Architect FlossWare  http://sourceforge.net/projects/flossware
CentOS mailing list
CentOS at centos.org

More information about the CentOS mailing list