[CentOS] Ndiswrapper refuses to install?

Marko Vojinovic vvmarko at gmail.com
Fri Mar 23 22:28:55 UTC 2012

On Friday, 23. March 2012. 21.36.54 Ned Slider wrote:
> On 23/03/12 21:16, Marko Vojinovic wrote:
> > I have a problem with making a wireless USB dongle work under CentOS 6.
> > The
> > dongle is known to not work natively under Linux and last time I used it
> > (cca 3 years ago) I managed to get it working using ndiswrapper.
> > 
> > This time I was hoping to make it work again in the same way. But the "yum
> > install kmod-ndiswrapper" reports the following (among other regular
> > stuff):
> > And yum refuses to install it. I've never seen this kind of report by yum.
> > What's going on here? And more importantly, how do I install
> > kmod-ndiswrapper on my up-to-date CentOS 6.2?
> First up, this is really the wrong list. kmod-ndiswrapper is from the
> elrepo repository so you should really report end user issues there, not
> here on the CentOS mailing list. But since we are here...

Right, sorry about that...
> This is a known issue - kmod-ndiswrapper fails on RHEL-6.2 due to kABI
> breakage. We tried rebuilding 1.56 against the 6.2 kernel but the code
> fails to compile. The best we could do was to update to 1.57-rc1
> (kmod-ndiswrapper-1.57-0.1.rc1.el6.elrepo.i686.rpm) which was the latest
> release at the time. This package has been in the testing repo since the
> release of RHEL-6.2 and has yet to receive any feedback - please feel
> free to be the first:

I see. Well, I just tried to install it, and it fails again, this time with a 
similar but different error:

# yum --enablerepo=elrepo-testing install kmod-ndiswrapper
[snip regular stuff]
Error: Package: kmod-ndiswrapper-1.57-0.1.rc1.el6.elrepo.i686 (elrepo-testing)
           Requires: ksym(__vmalloc) = 0x5705088a

So it still wants something my kernel doesn't seem to have. :-(

# uname -mri
2.6.32-220.7.1.el6.i686 i686 i386

> However, have you considered using a native Linux driver for your
> wireless? What chipset is it? The elrepo project has just released
> kmod-compat-wireless for el6 which is a backport of the kernel-3.3
> wireless stack supporting many wireless devices.
> http://elrepo.org/tiki/kmod-compat-wireless

This looks interesting. I just installed it, and it seems to be working! After 
plugging in the USB dongle, /var/log/messages correctly recognizes the device:

Mar 23 23:06:06 CicaMaca kernel: usb 1-2: new high speed USB device using 
ehci_hcd and address 2
Mar 23 23:06:06 CicaMaca kernel: usb 1-2: New USB device found, idVendor=1286, 
Mar 23 23:06:06 CicaMaca kernel: usb 1-2: New USB device strings: Mfr=1, 
Product=2, SerialNumber=0
Mar 23 23:06:06 CicaMaca kernel: usb 1-2: Product: 54M USB Wireless NIC      
Mar 23 23:06:06 CicaMaca kernel: usb 1-2: Manufacturer: Tenda.. 
Mar 23 23:06:06 CicaMaca kernel: usb 1-2: configuration #1 chosen from 1 choice

And lsusb now reports:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 1286:1fab Marvell Semiconductor, Inc. 88W8338 
[Libertas] 802.11g

Both "Tenda" and "Marvell" are correct. Now I'll try to start NetworkManager 
and see if I can get it to connect... :-)

Thanks for help!

Best, :-)

More information about the CentOS mailing list