[CentOS] Kickstart network issues

Fri Mar 16 20:49:19 UTC 2012
Daniel Lollman <daniel.lollman at resonateinsights.com>

Hello all -

(Please forgive me if I sent this msg twice, first one didn't seem to go through)

I searched through the archives and did not see anything about this (along with google), but if I missed something please don't hesitate to send me some links.

Basically I have hit a problem that I cannot figure out at this point and seemed to have ran out of ideas via Google or the documentation.

I am kickstarting (using cobbler) CentOS 6.2 installs over a private network (can reach the Internet). Part of the installations is to go grab various configuration files, rpm's, etc that are located both internal to the network (different subnet) and externally on the Internet somewhere. This problem seems to be intermittent since it works half of the time, but not the other half.

Any of my kickstart scripts I have that use local commands (not wget'ing files) work just fine no problems. However when it comes to getting things from the network, it does not always get those files. Usually this errors out with a cannot resolve hostname error or no route to host. I have tried the following to overcome this:

1)      During post-install, add a network start and sleep for 120 seconds to give it time to come up.

2)      Made sure that the "network" commands in the kickstart included -activate

3)      Tried making the downloads not depend on DNS which still does not work (no route to host).

Are there any tricks to ensuring the network comes up during post-install for kickstart?

By the way, after the kickstart is done and the VM boots up, there are no changes that need to be made to get the network up and running like normal... DNS, etc work fine immediately.

Thanks for any help,