[CentOS] 3TB usb drive won't mount

Thu Mar 22 12:39:29 UTC 2012
Barry Brimer <lists at brimer.org>

> I have a 3TB usb drive with an NTFS filesystem on it, that I can't mount.:
> [bent at bnlaptop ~]$ sudo /sbin/mount.ntfs-3g /dev/sdb1 /mnt
> Failed to read vcn 0xf28: Input/output error
> Failed to mount '/dev/sdb1': Input/output error
> NTFS is either inconsistent, or there is a hardware fault, or it's a
> SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
> then reboot into Windows twice. The usage of the /f parameter is very
> important! If the device is a SoftRAID/FakeRAID then first activate
> it and mount a different device under the /dev/mapper/ directory, (e.g.
> /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
> for more details.
> On a Win7 machine there are no problems and chkdsk can't find anything
> wrong with the filesystem.
> I can mount 1TB drives using ntfs-3g without problems, so the driver
> doesn't seem to be the issue.
> I've tried both CentOS6.2 and Fedora16 with the same result.

I wonder if it uses a GPT partition table or not.  I don't remember all 
the details, but for some reason I think you need a GPT partition table to 
handle partitions, filesystems, or something over 2 TB.