[CentOS] One disk speed problem [SOLVED], and a question on hdparm

Mon Mar 26 21:08:26 UTC 2012
John R Pierce <pierce at hogranch.com>

On 03/26/12 1:49 PM, m.roth at 5-cent.us wrote:
> So, here's the answer: we have these Caviar Green 2tb drives (the thread I
> found had either a 1tb, or 1.5tb), (and no, we are*NOT*  going to buy
> Caviar Green for servers ever again). The big thing is that they use 4k
> sectors,*not*  512 bytes. Following directions, I pulled it into fdisk,
> and then used a command I've not needed before: u. This changes units from
> cylinders (the default) to sectors. Having done that, p shows that it
> actually starts in sector 63. Again, following directions, I changed it to
> start in sector 64. Finished the partition, wrote it, made the filesystem,
> and tried it out.

almost all newer large capacity drives are using 4k sectors internally 
now.   SSD physical block sizes are something like 128k bytes, so the 
problem is even worse.

I'd suggest getting in the habit of using parted rather than fdisk, as 
fdisk can't handle GPT formatted disks, and MBR can't handle anything 
over 2TB

john r pierce                            N 37, W 122
santa cruz ca                         mid-left coast