[CentOS] Need help configuring wireless NIC

Tue Mar 27 10:07:15 UTC 2012
anax <anax at ayni.com>

Hi Marko
if your WLAN interface does not show up in ifconfig or in "ls -l 
/sys/class/net/ " then
- your system recognizes that it has to load the modules you mention 
when you plug in your WLAN interface
- but the modules are incapable to install the interface correctly

if you say you cannot bring to work ndiswrapper because its compilation 
fails, then you are in bad luck.

I once had a similar problem with a D-Link card (featuring the adx 
TI-chip). What I did: I waited until a new version of ndiswrapper was 
available, compiled this one, and off I went.


On 03/27/2012 08:46 AM, Marko Vojinovic wrote:
> On Tuesday, 27. March 2012. 10.02.25 Arun Khan wrote:
>> On Sat, Mar 24, 2012 at 10:05 PM, Marko Vojinovic<vvmarko at gmail.com>  wrote:
>>> Yesterday I managed to find a driver for my USB wireless dongle, and it is
>>> now correctly recognized by the kernel. However, I don't know how to
>>> configure it.
>> How did you install the driver that you found?
> Basically, I did this (following the advice of Ned Slider, from another
> thread):
> # yum --enablerepo=elrepo-testing kmod-compat-wireless
> # modprobe usb8xxx
> Namely, on the http://elrepo.org/tiki/kmod-compat-wireless there is a list of
> drivers corresponding to various devices. My device is
> # lsusb
> Bus 001 Device 006: ID 1286:1fab Marvell Semiconductor, Inc. 88W8338
> [Libertas] 802.11g
> so I did a search on the site for "1286" and found two relevant modules,
> usb8xxx and libertas. Modprobe-ing usb8xxx loads the following:
> # lsmod
> Module                  Size  Used by
> usb8xxx                13926  0
> libertas              105931  1 usb8xxx
> libertas_tf            12514  0
> mac80211              234108  1 libertas_tf
> cfg80211              164625  2 libertas,mac80211
> rfkill                 15242  1 cfg80211
> compat                 16607  2 mac80211,cfg80211
> lib80211                4194  1 libertas
> When I plug in the device, /var/log/messages says:
> Mar 27 08:10:30 CicaMaca kernel: usb 1-2: new high speed USB device using
> ehci_hcd and address 7
> Mar 27 08:10:31 CicaMaca kernel: usb 1-2: New USB device found, idVendor=1286,
> idProduct=1fab
> Mar 27 08:10:31 CicaMaca kernel: usb 1-2: New USB device strings: Mfr=1,
> Product=2, SerialNumber=0
> Mar 27 08:10:31 CicaMaca kernel: usb 1-2: Product: 54M USB Wireless NIC
> Mar 27 08:10:31 CicaMaca kernel: usb 1-2: Manufacturer: Tenda..
> Mar 27 08:10:31 CicaMaca kernel: usb 1-2: configuration #1 chosen from 1 choice
> which is basically the same information as found in dmesg. The device is
> correctly recognized, as far as it goes.
>> What is the output of "/sbin/ifconfig -a"  does it list the wifi
>> device i.e. wlan0 ?
> No, ifconfig lists only my two wired ethernet devices (eth0, eth1), and the
> openvpn virtual ethernet device (tap0). No mention of anything wireless.
>> Do "ethtool --driver<iface>  "   to find the driver associated with
>> your wifi network interface.
> What should<iface>  be? There isn't one associated to the wireless NIC, or I
> am unable to find it. I tried the following methods:
> # ifconfig -a
> # lshw -C network
> # rfkill list
> # iwconfig
> None of these report anything except my three wired devices (if at all).
> I vaguely understand that all these utilities are querrying the kernel for the
> info about hardware, but the kernel does not seem to be exposing it (or
> requires some non-automatic initialization). I tried looking at various places
> under /proc (to see if I can read something manually), but I found nothing,
> and TBH I don't quite know where to look.
>> Usuall the NetworkManager detects all the active network interfaces
>> and presents the devices.   In your case, I suspect the wifi device is
>> not being initialized.
> The NetworkManager does indeed give "some" indication that there is a wireless
> device, but it doesn't tell much. When I do a "service NetworkManager
> restart", this is the only relevant thing I recognized about wireless from
> /var/log/messages:
> Mar 27 08:24:24 CicaMaca NetworkManager[30454]:<info>  WiFi enabled by radio
> killswitch; enabled by state file
> Mar 27 08:24:24 CicaMaca NetworkManager[30454]:<info>  WWAN enabled by radio
> killswitch; enabled by state file
> Mar 27 08:24:24 CicaMaca NetworkManager[30454]:<info>  WiMAX enabled by radio
> killswitch; enabled by state file
> Mar 27 08:24:24 CicaMaca NetworkManager[30454]:<info>  Networking is enabled
> by state file
> Everything else is about eth0, eth1 and tap0 devices. I can provide full logs
> if you think I missed something.
> I am almost out of patience with this, and I'm already considering buying
> another wireless card, or rather a wireless router which can act as a client
> to another wireless router, so that I can connect the computer via wired
> ethernet. I'd prefer not to waste any money on this, especially if it is just
> a software configuration issue, but I also need the damn thing to start working
> sooner than later.
> Btw, the device is working properly under Windows, and it used to work
> properly under Linux with ndiswrapper. But current ndiswrapper fails to work
> (or even fails to compile) on current CentOS, so my only option is to try a
> native Linux driver from kmod-compat-wireless.
> If there is any way to make this work without throwing money at the problem,
> I'd appreciate to know. Also, if there isn't a way to make it work (in the
> next couple of days), I'd appreciate to know that as well. In that case, can
> you recommend any wireless device for a desktop machine which would work
> painlessly under CentOS? There might be a small chance I can buy it somewhere.
> Thanks for helping out! :-)
> Best, :-)
> Marko
> _______________________________________________
> CentOS mailing list
> CentOS at centos.org
> http://lists.centos.org/mailman/listinfo/centos