[CentOS] Problem installing 6.3 on HP8540w laptop

Thu Nov 15 20:17:44 UTC 2012
david <david at daku.org>

At 10:50 AM 11/15/2012, you wrote:
>david wrote:
> >
> > The Centos installation I chose was the "NetInstall".  The
> > installation process identified eth0, I selected IPV4 DHCP, disabled
> > IPV6, and successfully completed the install of "desktop" using the
> > wired connection through my home network.  The wireless was turned
> > off.  The ethernet controller shows up in Windows with the name "Intel
> > 8255LM".
> >
> > When the reboot occurred after installation, the Ethernet did not
> > work.  The "ifconfig eth0" command showed no IP address.  Where do I
> > go from here?
> >
>Hi, david. First question: does the laptop have a physical switch on the
>side that turns on/off wifi, the way Dells do?
>Try an lspci, and see if it shows.
>If it does, wireless will be wlan0, usually. Why your wired ethernet's not
>working - look at dmesg and/or /var/log/messages, and see if the driver
>was loaded. Next, look at /etc/sysconfig/network-scripts, and see if
>ifcfg-eth0 is turned on at boot.
>      mark

Thanks for the hints, Mark.  Here's what I found...

Wireless has no "physical" switch, but something I think is pretty 
much the same.  There's a lighted button above the keyboard which, I 
think, is interpreted directly by the bios.  It shows "off", and does 
change when pressed.  It is set off, which I suppose means that the 
radio is off.

The system does show both eth0 and wlan0, both as options during the 
net-install, and also in the "ifconfig" response.

Strangely, when I tried the install again just now, and selected 
"Desktop" (instead of "Minimal Desktop" as I did last time), all 
worked properly.  Ethernet works.  Perhaps the problem is that 
"minimal desktop" didn't include the ethernet drivers?

I guess I withdraw my complaint.