[CentOS] 8139 dropping packets

Sun Oct 28 04:15:14 UTC 2012
me at tdiehl.org <me at tdiehl.org>

On Sat, 27 Oct 2012, Jerry Geis wrote:

> I have a CentOS 5.8 box that is dropping packets (just from ping).
> The network is 8139 RTL-8139/8139C/8139C+ Rev 10
> Adding the parameters "pci=noacpi acpi=off "
> has helped but it still happens.
> Is there something else that helps the network not drop packets?

Upgrade to Centos 6. I have approx 20 jetway mini-itx boxes with a built
in 8139. I recently had all but 2 experience large packet loss problems.
Some of them were happily running C-5 for over 2 years. Upgrading them to C-6
solved it but I do not know why. I too would really like to understand what
is going on here.

In addition, I would like to know why I still have 2 boxes that are happily
running c-5.

I suspect that this is some kind of driver issue but I even tried upgrading
the drivers using those supplied by EL-Repo. The only thing that improved the
situation was upgrading to C-6.

FWIW, I use them as router/firewalls. They have a 3 port daughter board 
for a total of 4 Ethernet ports on them that I have recently switched to using
an Intel based chipset just as a precaution.


Tom			me at tdiehl.org		Spamtrap address	 		me123 at tdiehl.org