[CentOS] Network issue - Windows works but CentOS does not

Mon Oct 29 08:47:45 UTC 2012
xrx <xrx-centos at xrx.me>

On 10/27/12 21:54, xrx wrote:
> I am having an extremely strange issue with a BL460c1 (G1) blade on a
> c7000 enclosure. I could not for the life of me get the machine to ping
> the gateway or any other blade on the same enclosure (yes, the subnet
> mask was correct & quadruple-checked); although pinging to the local IP
> works. I was almost convinced that it was a network or hardware issue;
> until I asked someone to try installing Windows on that blade to verify
> that it was not working as well; however to my surprise it worked fine
> in Windows after installing the network driver; by just setting the IP
> address (which was the same IP I was trying to configure CentOS with).

I finally solved it; although a mystery remains. After getting a hint 
between differences in the network traffic between windows and linux, it 
turns out that if I specify the VLAN manually in CentOS; everything 
pings and works fine.

However, the strange part is that Windows did not require specifying the 
VLAN. I grudgingly installed Windows myself to verify that it works out 
of the box (the settings show it's set to VLAN 0 or disabled). I did a 
wireshark comparison between Windows Server 2008 R2 & CentOS on the same 
blade. What's unusual is that although both have pretty much identical 
ARP requests down to the mac addresses, the reply for the Windows one is 
normal with no mention of the VLAN; while the reply for the CentOS one 
has a 802.1Q Virtual LAN header with the ID (which I guess CentOS does 
not understand when its network is not configured for VLANs; and so 
repeats the ARP requests several times).

Anyway, I'm glad it's working fine now; hope this helps anyone in a 
similar situation at some point.