[CentOS] PHP version dilemma

John R. Dennison jrd at gerdesas.com
Fri Oct 5 13:51:11 EDT 2012

On Fri, Oct 05, 2012 at 07:06:14PM +0200, Leon Fauster wrote:
> @Todd: Just to clarify - the functionality and reliability 
>        of php53 is not restricted/"faulty" or what ever ...

Actually, it is.  The EL php53 package does not "Provide: php" so any
other package depending on that being present will fail to install
without force.  This may or may not be a show-stopper in any particular
environment.  There is also no php-mcrypt available in the base CentOS
updates and this is a matter that upstream will not fix; it is, however,
available from EPEL for those that need it.  There used to be a number
of other issues with the base php53 packages as supplied by TUV but
many, if not most, of these have been since resolved.  I no longer track
the issues as I've long since moved to IUS for php requirements.

As Brian pointed out earlier IUS is the go-to source for php53 / php54
packages that work.  Please see:


for more information.  There is also a yum-plugin-replace add-on from
IUS that will permit single transaction migration from stock php
packages to the IUS provided php53u packages.  Information is available
at the IUS website.

We're not ending the journey today, we're completing a chapter of a journey
that will never end.  Let's light this shuttle one more time ... and
witness this nation at its best.  The crew of Atlantis is ready to launch.

-- Atlantis Commander Chris Ferguson, just before the 11:29:29am EDT
   launch of STS-135, the final Space Shuttle mission, 8 July 2011
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.centos.org/pipermail/centos/attachments/20121005/98438149/attachment.bin 

More information about the CentOS mailing list