[CentOS] CentOS 6 early panic on ESXi 4.1.0 build 800380

Tue Sep 11 19:57:02 UTC 2012
Laurent <laurent at tnpl127.net>

Le 2012-09-11 21:06, Tilman Schmidt a écrit :
> I run VMware vSphere 4 Essentials with three almost identically
> configured ESXi 4.1 hosts and a mix of 32 and 64 bit guests including
> Windows 2003 and 2008 as well as CentOS 5 and 6. Recently I updated 
> one
> of the hosts to build 800380. The new build runs Windows and CentOS 5
> VMs fine, but CentOS 6 guests won't come up.
> I tried two different CentOS 6 VMs. Both have the latest standard 
> kernel
> (2.6.32-279.5.2.el6.x86_64). Both run perfectly fine on one of the 
> other
> VMware hosts still running ESXi 4.1.0 build 702113. On build 800380,
> both display the GRUB menu alright but freeze immediately afterwards,
> emitting the message

I've found what is probably your post on VMware Communities.

It seems there's a second 4.1 update 3 build (811144):

It fixes another panic, so trying this build may help.
PR722061: When a Linux kernel crashes, the linux kexec feature is used 
to enable booting into a special kdump kernel and gathering crash dump 
files. An SMP Linux guest configured with kexec might cause the virtual 
machine to fail with a monitor panic during this reboot. Error messages 
such as the following might be logged:

vcpu-0| CPU reset: soft (mode 2)
vcpu-0| MONITOR PANIC: vcpu-0:VMM fault 14: src=MONITOR 
rip=0xfffffffffc28c30d regs=0xfffffffffc008b50