[CentOS] NFS mounts group name shows as nobody

Thu Sep 13 05:43:59 UTC 2012
Barbara Krasovec <barbarak at arnes.si>

On 09/13/2012 12:35 AM, Johnny Hughes wrote:
> On 09/12/2012 05:10 PM, Ryan Palamara wrote:
>> So it is definitely related to NFS4. If I changed the default mount option to NFS3 there is no issue.
>> When I do a ls -n, I see that the GID of 99 is being used instead of the correct GID. I thought that a idmapd issues would cause both UID and GID to be wrong, or could this be causing an issue?
>> Any suggestions on what I can do in terms of logging to find what the GID is that is being returned from the NFS server and how it is trying to map it?
>> Thank you,
>> Ryan Palamara
>> ZAIS Group, LLC
>> 2 Bridge Avenue, Suite 322
>> Red Bank, New Jersey 07701
>> Phone: (732) 450-7444
>> Ryan.palamara at zaisgroup.com
>> -----Original Message-----
>> From: centos-bounces at centos.org [mailto:centos-bounces at centos.org] On Behalf Of Akemi Yagi
>> Sent: Wednesday, September 12, 2012 11:26 AM
>> To: CentOS mailing list
>> Subject: Re: [CentOS] NFS mounts group name shows as nobody
>> On Wed, Sep 12, 2012 at 5:29 AM, Barbara Krasovec <barbarak at arnes.si> wrote:
>>> Hello!
>>> The same problem appeared on our system (but both user and group were
>>> shown as nobody), with same idmapd.conf configured on server and
>>> client machines, users are in central ldap etc.. It worked fine with nfsv3.
>>> Then we installed the kernel from elrepo repository (tried both 2.6.39
>>> and 3.0) and it now works.
>> Sounds as if this is not the same issue as the existing one. The known issue should not apply if both the NFS client and server are part of the centralized LDAP domain.
Well problems are the same, is just that the solution provided in the 
Redhat kb (use central LDAP for authentication) doesn't work.
> Are you running idmapd (with the domain properly set in idmapd.conf) on
> *BOTH* the server and the client machines ... and are *BOTH* the server
> and the client machines set to use LDAP for authentication?
I use idmapd.conf with same Domain setting on all clients and servers, 
all have LDAP authentication..