[CentOS] DRM EDID Error

Mon Sep 17 15:08:26 UTC 2012
Lamar Owen <lowen at pari.edu>

On Sunday, September 16, 2012 11:11:01 PM Eugene Poole wrote:
> I know the monitor, keyboard, and mouse are not the problem because I 
> have 3 machines on a KVM using the same monitor, keyboard, and mouse.  
> Could this be my video card going bad? I read another posting where it 
> was suggested to add 'Option "IgnoreEDID" "1"' into the xorg.conf, but 
> this machine doesn't have a xorg.conf file.

I ran into this sort of issue due to the video cable.  If you're running with a KVM, you may want to check both the KVM to monitor cable and the video card to KVM cable.  Also try it straight to the monitor.  All video cables are not equal.

In the case that I ran into, the cable that came with the monitor worked well; a third party cable (new, not used, and not a 'cheap' cable) did not work at all for EDID information (that is, the resolution would not auto-set, and I couldn't get widescreen resolutions because of it).  The monitor was quite similar to your ViewSonic, and the video was almost the same exact card.  Once I went to the monitor's cable, everything worked perfectly.  Note that this particular cable was the 15 pin analog VGA cable, not a DVI cable.  

I'm not sure if it was the nVidia card being finicky, or if it was the monitor; it takes both to successfully grab the EDID info for auto-resolution.