[CentOS] BackupPC and rsync

Emmett Culley emmett at webengineer.com
Thu Sep 27 01:35:22 UTC 2012

On 09/26/2012 11:05 AM, Les Mikesell wrote:
> On Tue, Sep 25, 2012 at 10:33 PM, Emmett Culley <emmett at webengineer.com> wrote:
>> I have been using BackupPC via rsync daemons on the target machines and all has been working well.  At least until about the time rsync went to version 3.0.6.
>> Since then backups have been failing for some targets.  The failure is a TCP ZeroWindow issue.  It looks like the server rsync process cannot empty it's buffer soon enough and eventually the process fails.
>> I really do not know if it is rsync version related, because I never looked at the packet stream until I started having failures.
>> BackupPC was running on a VM host and the failing machine was one of the guest VMs. I tried upgrading rsync to 3.0.9 and that didn't help.
>> So I moved the BackupPC set up to a different server (no VM).  Not all backups are working. though I still see some ZeroWindow packets along with a few retransmision packets.  But the backup completes on all machines, including the VM that was failing before.
>> I've googled rsync zerowindow and found some references, but none seemed to apply to my situation.
>> Anybody else having a similar experience?
> I found an old mention of turning off TCP window scaling solving a
> problem with rsync (not involving backuppc).   Seems unlikely but
> might be worth a try: sysctl -w net.ipv4.tcp_window_scaling=0.

I tried that on the target VM and it didn't make any difference.  Then I tried it on the BackupPC server and that didn't make any difference either.

Thanks for the suggestion anyway.


More information about the CentOS mailing list