[CentOS] django not picking up template change on CentOS

Wed Sep 12 15:52:47 UTC 2012
Larry Martell <larry.martell at gmail.com>

Don't know if anyone here can help me or not, but here's my problem:

I have a django app. I develop on a Mac, but it's deployed on CentOS.
I've been doing it like this for a long time with no issues. Today I
changed a template on my Mac, and the change was picked up, no
problem. I checked my change into git, went to a CentOS box, pulled
the change down, but django is not picking it up. I've tried
everything I can think of - bounced the server, restarted the browser,
cleared the cache and cookies, tried 3 different browsers, deleted it,
re-pulled from git, but when I look at the code in the debugger, it's
clearly using the old template. There are no errors in the apache log,
and permissions are fine. One thing I see is that is different is that
the dir that has the new template, has no SELinux security context
set, whereas all the other dirs do. But SELinux is disabled on this
box, so that's probably not it. I've been trying to set the SELinux
security context on that dir, just so it's like the others, but I
haven't been able to figure out how to do that - I don't know what to
pass to chcon.

I'm tearing my hair out here. Anyone have any ideas as to what's
preventing it from picking up the new template, or what I can check to
figure out what's going on?